Verification is currently underway for the maintenance items.
Posted Apr 02, 2025 - 16:21 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 09:00 PDT
Scheduled
Our engineers are performing server maintenance, which may intermittently impact account access, syncing, sharing of data, etc. Updates will be posted here. If you subscribe to this page, updates will be emailed to you automatically.
Posted Apr 01, 2025 - 08:57 PDT
This scheduled maintenance affects: Applications (Web Application, Desktop Application, Mobile Applications) and Other (Search, Emails, Two-Factor Authentication (2FA)).